読者です 読者をやめる 読者になる 読者になる

メモ:Gradle で Java8 のビルドが失敗したけど直った

sourceCompatibility = targetCompatibility = '1.8'

上のように 1.8 にしてビルドすると、

1.8は無効なソース・リリースです

とエラーが出ました。
Gradle 1.10 and Java8 / JDK8: invalid source release: 1.8
Gradle build with Java 8 - Stack Overflow
調べても JAVA_HOME が Java8 になってないんじゃね?
みたいなのが多かったのですが、
%USERPROFILE%/.gradle を一旦削除してから実行すると、ビルド出来るようになりました。