読者です 読者をやめる 読者になる 読者になる

JDBC Driver 4.2 / 6.0 Preview for SQL Server は Java 7以下で動きませんよ!

SQL Server Java

JDBC Driver4.2 (Preview) for SQL Server は JDK8 のみ動作する? - お だ のスペース
JDBC Driver 4.2 for SQL Server がリリースされてました - お だ のスペース

以前にも書いたのですが、JDBC Driver 4.2 以降は、Java 7以下は動作しません。
System Requirements for the JDBC Driver
の sqljdbc42.jar の箇所に、

Requires a Java Runtime Environment (JRE) 8.0. Using JRE 7.0 or lower will throw an exception.

と記載があります。

今さらこんなの書いたのは、公式?のブログに 4.2 系のサポートが 5, 6, 7, 8 と載ってたので。
SQL Server データアクセスレイヤーについて – Microsoft Japan Data Platform Tech Sales Team Blog

もちろんブログも悪いのですが、大元のダウンロードページのシステム要件が間違っているのが問題。
Download Microsoft JDBC Driver 6.0 for SQL Server、Microsoft JDBC Driver 4.2 for SQL Server、Microsoft JDBC Driver 4.1 for SQL Server、および Microsoft JDBC Driver 4.0 for SQL Server from Official Microsoft Download Center

フィードバック上げた気がするけど、も一回上げときました。
bug JDBC Driver 4.2 download page system requirements. | Microsoft Connect

※2016/08/03 追記
今見たらダウンロードページのシステム要件が修正されてました。良かった~。